Friday, December 07, 2007

Having problems updating to Rails 2.0 under Windows XP?

Seeing this error while trying to install Rails 2.0?
ERROR: While executing gem … (Zlib::BufError) buffer error
Run
gem update --system
first.

Then run
gem install rails -y --source http://gems.rubyonrails.org
and you're all set!

Yeah, I didn't know my RubyGems was that far out of date, either.

3 comments:

mr_gent said...

nice thanks i was having this problem on Vista.

Julian said...

Thanks Arron! Magic.

Bet's On said...

No problem.